Report a bug #343

Jobs with output file format "IMS (Imaris Classic)" fail

Added by Anonymous over 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:2014-12-22
Priority:NormalDue date:
Assignee:Aaron% Done:

100%

Category:Bug
Target version:HRM Development - 3.3.0

Description

Dear HRM developers,

when I select "IMS (Imaris Classic)" as the output file format in step 4 of the job creation wizard, the job fails. The status mail does not indicate any error (other than that it states in the subject that the job failed). The log file /var/log/hrm/hrm.log shows the following error:

2014-12-22 02:08:26 processing job 54976f0871f9c on localhost
2014-12-22 02:08:26 Job is elementary
2014-12-22 02:08:28 Wrote template /local/data/huygens_data/test/src/.hrm_54976f0871f9c.hgsb
2014-12-22 02:08:28 Created Huygens template
2014-12-22 02:08:28 template has been created
2014-12-22 02:08:28 shell process created
2014-12-22 02:08:28 running shell: /local/data/huygens_data/test/src/.hrm_54976f0871f9c.hgsb
2014-12-22 02:08:34 running template (pid 3670)
2014-12-22 02:08:34 Template has been executed
2014-12-22 02:08:34 job has been started (2014-12-22 02:08:34)
2014-12-22 02:09:27 Problem: no result file testfilelif_lif_54976f0871f9c_hrm.ims in destination directory /local/data/huygens_data/test/dst/
2014-12-22 02:09:27 finishing job 54976f0871f9c with error on localhost
2014-12-22 02:09:27 cleaning up file server
2014-12-22 02:09:27 stopped job (Monday 22 December 2014 02:09:27)

It complains about a missing file, but the status mail says "Successfully saved result to: /local/data/huygens_data/test/dst/testfilelif_lif_54976f0871f9c_hrm.ims".

If I look inside the destination directory, I only find a similarly named file (note the _t0000):

testfilelif_lif_54976f0871f9c_hrm_t0000.ims

The output file looks like a legit result. I suspect that HRM simply expects the file to be named differently, but that - other than that - everything is fine.

History

#1 Updated by Aaron over 5 years ago

Does the original file contain more than one time point? Have you specified a time interval?

#2 Updated by Aaron over 5 years ago

  • Target version set to 11

#3 Updated by Sebastian over 5 years ago

The job settings say:

time interval: not set

As far as I can see the image has only one time point. (I didn't make the image, but when I opened it in Fiji and told it to split by time point, it opened only one window.) Is there a nifty command or log file of HRM that can prints some metadata about the image?

#4 Updated by Aaron over 5 years ago

Do you have Huygens Pro or Essential?
- can you open the original file and look at the paramteters (number of time points in particular)?
- what happens if you run a deconvolution with the same parameters as in the HRM ans save the result as IMS classic?
- what happens if save the raw input file itself as IMS classic?

#5 Updated by Aaron over 5 years ago

  • Target version changed from 11 to 3.3.0

#6 Updated by Sebastian over 5 years ago

- can you open the original file and look at the paramteters (number of time points in particular)?

Huygens Essential says:

number of time frames: 1

- what happens if you run a deconvolution with the same parameters as in the HRM ans save the result as IMS classic?
- what happens if save the raw input file itself as IMS classic?

Regardless of whether I try to save the original file or run a deconvolution on the original file and try to save the deconvolved file, the following happens:

When I use Huygens Essential to save the file in IMS format, I get the following pup-up error messages:

Low level function 'ImarisWrite' exited with error: Failed to write file.

ImarisWrite: Low level image processing function faulted

A file with extension ".ims" is created, but it seems corrupt (meaning, I cannot open it with Huygens Essential). Moreover, Huygens Essential automatically adds the suffix "_t0000" like HRM did.

#7 Updated by Daniel over 5 years ago

Hello Sebastian,

This seems to be a problem in the Huygens IMS writer. Would it be possible for you to upload the image to the SVI FTP so that the issue can be further investigated?

Please see http://www.svi.nl/FtpUpload for details on how to upload the data.

Thanks a lot,
Daniel Sevilla

#8 Updated by Sebastian over 5 years ago

Hi Daniel,

Sorry for the delay. The user took a while to respond. In the meantime, I found an image myself on the web to reproduce the issue. I uploaded it to the FTP server as "bug_report_343.zip".

Regards,
Sebastian

#9 Updated by Aaron over 4 years ago

  • Assignee set to Aaron

Disable Imaris classic as output format for time series (i.e. when the time interval is larger than 0).

#10 Updated by Aaron over 4 years ago

  • Status changed from New to Resolved - Test / Merge
  • % Done changed from 0 to 100

I checked in the code: it seems to have been solved already. Currently, when the time interval is > 0 or autoseries is enabled, the Imaris Classic format is from the list of options. For good measure, in case it still was selected (it shouldn't be possible, but who knows?), it is reset to ics.

#11 Updated by Daniel over 4 years ago

  • Status changed from Resolved - Test / Merge to Closed

Also available in: Atom PDF